Dev/Java

for문에서 변수명 이렇게 쓰지마라!!

healthyryu 2017. 11. 14. 15:11
반응형

for 문에 사용하는 변수명!!


프로그래밍을 하다보면 당연(?)하게 for 문을 작성하게 된다. 아마도?!


ArrayList<String> list = new ArrayList<>();


for (int i = 0; i < list.size(); i++) {

  ArrayList<String> strList = new ArrayList<>();

  // ....

  

for (int j = 0; j < strList.size(); j++) {

//....

}

}


위와 같이 나는 작성을 했었다.

따로 어디선가 받아오는 변수 명이 아닐 경우에 해당 for 문int i 와 같이 i 를 주로 썼었다. 그리고 언젠가 웹인지 책인지 어딘지 모르겠지만 for 문 안에 사용하는 변수명을 i 와 같이 명명하지 말라고 했었다. 명확성이 떨어지고 나중에 코드를 봤을때 이해하기 어려울 수도 있다고 했다.

오늘 기존의 소스코드의 오류를 찾고 있었다. 로직상에 별 문제가 없는데 기대값과 자꾸 다르게 나왔었다. 그리고 한참보다보니 i, j 가 있어야할 곳에 있지 않음을 알았다. 그리고 수정을 하니깐 기대하던 값이 나왔다.


코드가 길어지거나 다른 사람의 코드를 분석하고 수정해야할 일이 있을때 맞딱드릴 수 있는 문제라는걸 알게 되었다.

요즘에는 foreach 문을 쓰는게 좀 더 명확하거나 쓰기도 편하긴 하지만 for 문을 쓴다면 변수명을 의미 있는 단어로 쓰도록 유의해서 써야한다!!

반응형
1 2 3 4 5 6 7 8